Blog update

Contributed by
Mar 12, 2008
<?xml encoding="utf-8" ?>

Folks, sorry about not having a new post up for the past day. Things have been interesting.

Have you noticed over the past couple of weeks how the BA site is sometimes incredibly slow or not accessible? I was getting huge numbers of hits from Digg, Slashdit, and Reddit, which were clogging the server to a standstill. So, with Fraser's help (well, he basically did everything) we moved the entire site to a new server.

This new machine is very beefy, and appears to be handling things very well -- the Mythbusters post below is getting hit from Digg like nothing I have ever seen, and the CPU on the server is humming right along. Yay!

However (Warning: tech geekery ahoy!) to move a site to a different location you have to let all the computers on the planet know it. We updated the Domain Name Servers, but that takes a few hours sometimes to propagate throughout the web. I could just say that I wasn't seeing the new server until just now, but that's not quite true: basically, my Mac hadn't cleared out the port, so even after refreshing and clearing my cache I was still seeing the old server. It occurred to me just now to reboot my Mac, and bang! Now I am seeing the new server. :-)

So that's why I haven't posted. But now everything is lovely and shiny, and I'm back. If you are reading this, then you are seeing the new server as well and you're all set. If you're not reading this, then why am I writing it other than to fall into some sort of tautological singularity?

Anyway, I'll have an actual post up in a little while. I appreciate everyone's patience!